Skip to content

← Actionable
Medium, CVSS 6.5

Mautic's Predictable Page Indexing Might Lead to Sensitive Data Exposure

CVE-2025-5257GHSA-cqx4-9vqf-q3m8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.2, 5.2.6, 4.4.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 4.0.0, < 4.4.16>= 5.0.0-alpha, < 5.2.6>= 6.0.0-alpha, < 6.0.2
    Fixed in
    5.2.6, 4.4.16, 6.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
EPSS
  • CVE-2025-5257: 0.36% estimated exploitation activity in the next 30 days; percentile 30.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This advisory addresses a security vulnerability in Mautic where unpublished page previews could be accessed by unauthenticated users and potentially indexed by search engines. This could lead to the unintended disclosure of draft content or sensitive information. Unauthorized Access to Unpublished Page Previews: The page preview functionality for unpublished content, accessible via predictable URLs (e.g., /page/preview/1, /page/preview/2), lacked proper authorization checks. This allowed any unauthenticated user to view content that was not yet intended for public release, and allowed search engines to index these private preview URLs, making the content publicly discoverable. Mitigation Mautic has patched this vulnerability by enforcing proper permission checks on preview pages. Users should upgrade to the patched version of Mautic or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cqx4-9vqf-q3m8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-5257

Advisory: Mautic's Predictable Page Indexing Might Lead to Sensitive Data Exposure
IDs: CVE-2025-5257, GHSA-cqx4-9vqf-q3m8
Record: https://patchnext.com/advisories/cve-2025-5257 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.2, 5.2.6, 4.4.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 4.0.0, < 4.4.16; >= 5.0.0-alpha, < 5.2.6; >= 6.0.0-alpha, < 6.0.2; fixed in 5.2.6, 4.4.16, 6.0.2

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cqx4-9vqf-q3m8 (GitHub-reviewed advisory GHSA-cqx4-9vqf-q3m8 lists affected ranges: Packagist mautic/core >=4.0.0 =5.0.0-alpha =6.0.0-alpha <6.0.2)

Commands are suggestions: review each one before running it.

Loading voting…