Skip to content

← Actionable
High, CVSS 7.3

runc container escape with malicious config due to /dev/console mount and related races

CVE-2025-52565GHSA-qw9x-cqr3-wc7r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/opencontainers/runc 1.4.0-rc.3, 1.3.3, 1.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-52565: 0.81% estimated exploitation activity in the next 30 days; percentile 56.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact

This attack is very similar in concept and application to CVE-2025-31133, except that it attacks a similar vulnerability in a different target (namely, the bind-mount of /dev/pts/$n to /dev/console as configured for all containers that allocate a console). In runc version 1.0.0-rc3 and later, due to insufficient checks when bind-mounting /dev/pts/$n to /dev/console inside the container, an attacker can trick runc into bind-mounting paths which would normally be made read-only or be masked onto a path that the attacker can write to. This happens after pivotroot(2), so this cannot be used to write to host files directly -- however, as with CVE-2025-31133, this can load to denial of service of the host or a container breakout by providing the attacker with a writable copy of /proc/sysrq-trigger or /proc/sys/kernel/corepattern (respectively). The reason that the attacker can gain write access to these files is because the /dev/console bind-mount happens before maskedPaths and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qw9x-cqr3-wc7r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52565

Advisory: runc container escape with malicious config due to /dev/console mount and related races
IDs: CVE-2025-52565, GHSA-qw9x-cqr3-wc7r
Record: https://patchnext.com/advisories/cve-2025-52565 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/opencontainers/runc 1.4.0-rc.3, 1.3.3, 1.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/opencontainers/runc: affected >= 1.0.0-rc3, <= 1.2.7; >= 1.3.0-rc.1, <= 1.3.2; >= 1.4.0-rc.1, <= 1.4.0-rc.2; fixed in 1.2.8, 1.3.3, 1.4.0-rc.3

## Suggested inspection (read-only)
- Go github.com/opencontainers/runc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/opencontainers/runc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qw9x-cqr3-wc7r (GitHub-reviewed advisory GHSA-qw9x-cqr3-wc7r lists affected ranges: Go github.com/opencontainers/runc >=1.0.0-rc3 =1.3.0-rc.1 =1.4.0-rc.1 <=1.4.0-rc.2)

Commands are suggestions: review each one before running it.

Loading voting…