Skip to content

← Actionable
Medium, CVSS 5.4

Mautic has an Open Redirect vulnerability on user unlock path.

CVE-2025-5256GHSA-6vx9-9r2g-8373

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.2, 5.2.6, 4.4.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 1.0.0, < 4.4.16>= 5.0.0-alpha, < 5.2.6>= 6.0.0-alpha, < 6.0.2
    Fixed in
    5.2.6, 4.4.16, 6.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-5256: 0.25% estimated exploitation activity in the next 30 days; percentile 16.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This advisory addresses an Open Redirection vulnerability in Mautic's user unlocking endpoint. This vulnerability could be exploited by an attacker to redirect legitimate users to malicious websites, potentially leading to phishing attacks or the delivery of exploit kits. Open Redirection via returnUrl Parameter: An Open Redirection vulnerability exists in the /s/action/unlock/user.user/0 endpoint. The returnUrl parameter, intended for post-action redirection, is not properly validated. This allows an attacker to craft a URL that, when clicked by a user, redirects them to an arbitrary external website controlled by the attacker. Mitigation Update Mautic to a version that properly validates or sanitizes the returnUrl parameter to ensure that redirects only occur to trusted, internal URLs or explicitly whitelisted domains.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6vx9-9r2g-8373

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-5256

Advisory: Mautic has an Open Redirect vulnerability on user unlock path.
IDs: CVE-2025-5256, GHSA-6vx9-9r2g-8373
Record: https://patchnext.com/advisories/cve-2025-5256 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.2, 5.2.6, 4.4.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 1.0.0, < 4.4.16; >= 5.0.0-alpha, < 5.2.6; >= 6.0.0-alpha, < 6.0.2; fixed in 5.2.6, 4.4.16, 6.0.2

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6vx9-9r2g-8373 (GitHub-reviewed advisory GHSA-6vx9-9r2g-8373 lists affected ranges: Packagist mautic/core >=1.0.0 =5.0.0-alpha =6.0.0-alpha <6.0.2)

Commands are suggestions: review each one before running it.

Loading voting…