ChangeDetection.io XSS in watch overview
CVE-2025-52558GHSA-hwpg-x5hw-vpv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.50.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI changedetection-io
- Affected
- <= 0.50.3
- Fixed in
- 0.50.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hwpg-x5hw-vpv9 lists affected ranges: PyPI changedetection-io >=0 <0.50.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hwpg-x5hw-vpv9 lists affected ranges: PyPI changedetection-io >=0 <=0.50.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-52558: 0.59% estimated exploitation activity in the next 30 days; percentile 48.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact XSS - Errors in filters from website page change detection watches were not being filtered. Patches 0.50.4
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hwpg-x5hw-vpv9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hwpg-x5hw-vpv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52558 Advisory: ChangeDetection.io XSS in watch overview IDs: CVE-2025-52558, GHSA-hwpg-x5hw-vpv9 Record: https://patchnext.com/advisories/cve-2025-52558 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.50.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI changedetection-io: affected <= 0.50.3; fixed in 0.50.4 ## Suggested inspection (read-only) - `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on changedetection-io. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hwpg-x5hw-vpv9 (OSV record GHSA-hwpg-x5hw-vpv9 lists affected ranges: PyPI changedetection-io >=0 <0.50.4 (fixed)) - Verified: https://github.com/advisories/GHSA-hwpg-x5hw-vpv9 (GitHub-reviewed advisory GHSA-hwpg-x5hw-vpv9 lists affected ranges: PyPI changedetection-io >=0 <=0.50.3) Commands are suggestions: review each one before running it.
Loading voting…