Skip to content

← Actionable
Critical, CVSS 9.3amended

rfc3161-client has insufficient verification for timestamp response signatures

CVE-2025-52556GHSA-6qhv-4h7r-2g9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rfc3161-client 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-52556: 0.17% estimated exploitation activity in the next 30 days; percentile 6.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact rfc3161-client 1.0.2 and earlier contain a flaw in their timestamp response signature verification logic. In particular, it performs chain verification against the TSR's embedded certificates up to the trusted root(s), but fails to verify the TSR's own signature against the timestamping leaf certificates. Consequently, vulnerable versions perform insufficient signature validation to properly consider a TSR verified, as the attacker can introduce any TSR signature so long as the embedded leaf chains up to some root TSA. Patches Users should immediately upgrade to rfc3161-client 1.0.3 or later. Workarounds There is no workaround possible. Users should immediately upgrade to a fixed version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6qhv-4h7r-2g9m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6qhv-4h7r-2g9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52556

Advisory: rfc3161-client has insufficient verification for timestamp response signatures
IDs: CVE-2025-52556, GHSA-6qhv-4h7r-2g9m
Record: https://patchnext.com/advisories/cve-2025-52556 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rfc3161-client 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI rfc3161-client: affected <= 1.0.2; fixed in 1.0.3

## Suggested inspection (read-only)
- `python -m pip show rfc3161-client`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rfc3161-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6qhv-4h7r-2g9m (OSV record GHSA-6qhv-4h7r-2g9m lists affected ranges: PyPI rfc3161-client >=0 <1.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6qhv-4h7r-2g9m (GitHub-reviewed advisory GHSA-6qhv-4h7r-2g9m lists affected ranges: PyPI rfc3161-client >=0 <=1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…