DNN.PLATFORM Allows Reflected Cross-Site Scripting (XSS) in some TokenReplace situations with SkinObjects
CVE-2025-52486GHSA-pf4h-vrv6-cmvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dnn.platform 10.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet dnn.platform
- Affected
- >= 6.0.0, < 10.0.1
- Fixed in
- 10.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pf4h-vrv6-cmvr lists affected ranges: NuGet dnn.platform >=6.0.0 <10.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2025-52486: 0.23% estimated exploitation activity in the next 30 days; percentile 13.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
DNN.PLATFORM allows specially crafted content in URLs could be used with TokenReplace and not be properly sanitized by some SkinObjects. This vulnerability is fixed in 10.0.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pf4h-vrv6-cmvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52486 Advisory: DNN.PLATFORM Allows Reflected Cross-Site Scripting (XSS) in some TokenReplace situations with SkinObjects IDs: CVE-2025-52486, GHSA-pf4h-vrv6-cmvr Record: https://patchnext.com/advisories/cve-2025-52486 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dnn.platform 10.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet dnn.platform: affected >= 6.0.0, < 10.0.1; fixed in 10.0.1 ## Suggested inspection (read-only) - NuGet dnn.platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dnn.platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pf4h-vrv6-cmvr (GitHub-reviewed advisory GHSA-pf4h-vrv6-cmvr lists affected ranges: NuGet dnn.platform >=6.0.0 <10.0.1) Commands are suggestions: review each one before running it.
Loading voting…