Skip to content

← Actionable
Low, CVSS 2.7

zkVM Underconstrained Vulnerability

CVE-2025-52484GHSA-g3qg-6746-3mg9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (risc0-circuit-rv32im 2.0.4; risc0-zkvm 2.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-52484: 0.27% estimated exploitation activity in the next 30 days; percentile 19.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Due to a missing constraint in the rv32im circuit, any 3-register RISC-V instruction (including remu and divu) in risc0-zkvm 2.0.0, 2.0.1, and 2.0.2 are vulnerable to an attack by a malicious prover. The main idea for the attack is to confuse the RISC-V virtual machine into treating the value of the rs1 register as the same as the rs2 register due to a lack of constraints in the rv32im circuit. This vulnerability was reported by Christoph Hochrainer via our Hackenproof bug bounty. We have evaluated the severity of the vulnerability as “Critical,” and paid a bounty. The fix for the circuit was implemented in zirgen/pull/238, and the update to risc0 was implemented in risc0/pull/3181. Impacted on-chain verifiers have already been disabled via the estop mechanism outlined in the Verifier Management Design. Mitigation We recommend all impacted users upgrade as soon as possible. Rust applications using the risc0-zkvm crate at versions 2.0.0, 2.0.1, and 2.0.2 should upgrade to version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g3qg-6746-3mg9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52484

Advisory: zkVM Underconstrained Vulnerability
IDs: CVE-2025-52484, GHSA-g3qg-6746-3mg9
Record: https://patchnext.com/advisories/cve-2025-52484 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: risc0-circuit-rv32im 2.0.4; risc0-zkvm 2.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io risc0-circuit-rv32im: affected >= 2.0.0, <= 2.0.3; fixed in 2.0.4
- crates.io risc0-zkvm: affected >= 2.0.0, <= 2.0.2; fixed in 2.1.0

## Suggested inspection (read-only)
- crates.io risc0-circuit-rv32im: check the installed version with your package manager.
- crates.io risc0-zkvm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on risc0-circuit-rv32im, risc0-zkvm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g3qg-6746-3mg9 (GitHub-reviewed advisory GHSA-g3qg-6746-3mg9 lists affected ranges: crates.io risc0-zkvm >=2.0.0 =2.0.0 <=2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…