Skip to content

← Actionable
High, CVSS 8.7amended

Stored XSS in n8n Form Trigger allows Account Takeover via injected iframe and video/source

CVE-2025-52478GHSA-hfmv-hhh3-43f2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.98.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 1.77.0, < 1.98.2
    Fixed in
    1.98.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2025-52478: 0.39% estimated exploitation activity in the next 30 days; percentile 33.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A stored Cross-Site Scripting (XSS) vulnerability was identified in n8n, specifically in the Form Trigger node's HTML form element. An authenticated attacker can inject malicious HTML via an <iframe with a srcdoc payload that includes arbitrary JavaScript execution. The attacker can also inject malicious Javascript by using <video coupled <source using an onerror event. While using iframe or a combination of video and source tag, this vulnerability allows for Account Takeover (ATO) by exfiltrating n8n-browserId and session cookies from authenticated users who visit a maliciously crafted form. Using these tokens and cookies, an attacker can impersonate the victim and change account details such as email addresses, enabling full control over the account—especially if 2FA is not enabled. Patches The issue was addressed in PR #16329. Users should upgrade to version =1.98.2. Workarounds Apart from updating to the fixed version, n8n instance administrators can: - Configure a reverse…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hfmv-hhh3-43f2

  2. Revision 1 · created ·

    Published from osv record GHSA-hfmv-hhh3-43f2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52478

Advisory: Stored XSS in n8n Form Trigger allows Account Takeover via injected iframe and video/source
IDs: CVE-2025-52478, GHSA-hfmv-hhh3-43f2
Record: https://patchnext.com/advisories/cve-2025-52478 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.98.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 1.77.0, < 1.98.2; fixed in 1.98.2

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hfmv-hhh3-43f2 (OSV record GHSA-hfmv-hhh3-43f2 lists affected ranges: npm n8n >=1.77.0 <1.98.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hfmv-hhh3-43f2 (GitHub-reviewed advisory GHSA-hfmv-hhh3-43f2 lists affected ranges: npm n8n >=1.77.0 <1.98.2)

Commands are suggestions: review each one before running it.

Loading voting…