XWiki Platform is vulnerable to HQL injection via wiki and space search REST API
CVE-2025-52472GHSA-gprp-h92g-gc2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-rest-server 17.4.2, 16.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-rest-server
- Affected
- >= 17.0.0-rc-1, < 17.4.2>= 4.3-milestone-1, < 16.10.9
- Fixed in
- 17.4.2, 16.10.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gprp-h92g-gc2h lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=17.0.0-rc-1 =4.3-milestone-1 <16.10.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-52472: 2.37% estimated exploitation activity in the next 30 days; percentile 83.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The REST search URL is vulnerable to HQL injection via the orderField parameter. The specified value is added twice in the query, though, once in the field list for the select and once in the order clause, so it's not that easy to exploit. The part of the query between the two fields can be enclosed in single quotes to effectively remove them, but the query still needs to remain valid with the query two times in it. For example, with the following orderField parameter: See the following error: For reference, the full URL for the above error is: Patches This has been patched in 17.5.0, 17.4.2, 16.10.9. Workarounds There is no known workaround, other than upgrading XWiki. Resources https://jira.xwiki.org/browse/XWIKI-23247 https://github.com/xwiki/xwiki-platform/commit/743ebf8696ffa55161ed2c5ecf26b09f69e6bcf1 https://github.com/xwiki/xwiki-platform/commit/a45eca2af772abb7324e56d7fd2df1ac937bc445 For more information If you have any questions or comments about this advisory: Open…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gprp-h92g-gc2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52472 Advisory: XWiki Platform is vulnerable to HQL injection via wiki and space search REST API IDs: CVE-2025-52472, GHSA-gprp-h92g-gc2h Record: https://patchnext.com/advisories/cve-2025-52472 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-rest-server 17.4.2, 16.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-rest-server: affected >= 17.0.0-rc-1, < 17.4.2; >= 4.3-milestone-1, < 16.10.9; fixed in 17.4.2, 16.10.9 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-rest-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-rest-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gprp-h92g-gc2h (GitHub-reviewed advisory GHSA-gprp-h92g-gc2h lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=17.0.0-rc-1 =4.3-milestone-1 <16.10.9) Commands are suggestions: review each one before running it.
Loading voting…