Skip to content

← Actionable
High, CVSS 7.2

GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page

CVE-2025-52465GHSA-7qmg-grcp-qf25

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.web:gs-web-sec-core 2.27.3, 2.26.4; org.geoserver.web:gs-web-app 2.27.3, 2.26.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-52465: 0.62% estimated exploitation activity in the next 30 days; percentile 49.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability exists that allows an authenticated administrator with access to GeoServer's security system to pass arbitrary file names to the Master Password Dump web page and create files containing the master password in plaintext. The provided file name must be an absolute path to the target file, the target file can not already exist and all parent directories must already exist. Details When dumping the master password, GeoServer will use the provided file name with minimal validation as long as it is a java.io.File path. The only limitation is that the fix for a previous, unrelated vulnerability prevents relative path traversal here but absolute paths can be used to access arbitrary files. GeoServer does not enforce a maximum password length by default which allows an administrator to place malicious code into their password which could then be dumped into a JSP file. Impact Remote Code Execution (High severity) This vulnerability can lead to executing arbitrary code…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7qmg-grcp-qf25

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-52465

Advisory: GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page
IDs: CVE-2025-52465, GHSA-7qmg-grcp-qf25
Record: https://patchnext.com/advisories/cve-2025-52465 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver.web:gs-web-sec-core 2.27.3, 2.26.4; org.geoserver.web:gs-web-app 2.27.3, 2.26.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver.web:gs-web-sec-core: affected >= 2.27.0, <= 2.27.2; <= 2.26.3; fixed in 2.27.3, 2.26.4
- Maven org.geoserver.web:gs-web-app: affected >= 2.27.0, <= 2.27.2; <= 2.26.3; fixed in 2.27.3, 2.26.4

## Suggested inspection (read-only)
- Maven org.geoserver.web:gs-web-sec-core: check the installed version with your package manager.
- Maven org.geoserver.web:gs-web-app: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver.web:gs-web-sec-core, org.geoserver.web:gs-web-app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7qmg-grcp-qf25 (GitHub-reviewed advisory GHSA-7qmg-grcp-qf25 lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.27.0 =0 =2.27.0 =0 <=2.26.3)

Commands are suggestions: review each one before running it.

Loading voting…