The Freeform CraftCMS plugin contains an Server-side template injection (SSTI) vulnerability
CVE-2025-52122GHSA-9hp3-f5g8-rccg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (solspace/craft-freeform 5.10.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist solspace/craft-freeform
- Affected
- >= 5.0.0, < 5.10.16
- Fixed in
- 5.10.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hp3-f5g8-rccg lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <5.10.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-52122: 0.61% estimated exploitation activity in the next 30 days; percentile 49.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Freeform 5.0.0 to before 5.10.16, a plugin for CraftCMS, contains an Server-side template injection (SSTI) vulnerability, resulting in arbitrary code injection for all users that have access to editing a form (submission title).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9hp3-f5g8-rccg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-52122 Advisory: The Freeform CraftCMS plugin contains an Server-side template injection (SSTI) vulnerability IDs: CVE-2025-52122, GHSA-9hp3-f5g8-rccg Record: https://patchnext.com/advisories/cve-2025-52122 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: solspace/craft-freeform 5.10.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist solspace/craft-freeform: affected >= 5.0.0, < 5.10.16; fixed in 5.10.16 ## Suggested inspection (read-only) - Packagist solspace/craft-freeform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on solspace/craft-freeform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9hp3-f5g8-rccg (GitHub-reviewed advisory GHSA-9hp3-f5g8-rccg lists affected ranges: Packagist solspace/craft-freeform >=5.0.0 <5.10.16) Commands are suggestions: review each one before running it.
Loading voting…