pypickle unsafe deserialization vulnerability
CVE-2025-5174GHSA-5qwj-342r-h886
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pypickle 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pypickle
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5qwj-342r-h886 lists affected ranges: PyPI pypickle >=0 <2.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5qwj-342r-h886 lists affected ranges: PyPI pypickle >=0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-5174: 0.34% estimated exploitation activity in the next 30 days; percentile 27.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5qwj-342r-h886
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5qwj-342r-h886
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-5174 Advisory: pypickle unsafe deserialization vulnerability IDs: CVE-2025-5174, GHSA-5qwj-342r-h886 Record: https://patchnext.com/advisories/cve-2025-5174 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pypickle 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pypickle: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - `python -m pip show pypickle`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pypickle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5qwj-342r-h886 (OSV record GHSA-5qwj-342r-h886 lists affected ranges: PyPI pypickle >=0 <2.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5qwj-342r-h886 (GitHub-reviewed advisory GHSA-5qwj-342r-h886 lists affected ranges: PyPI pypickle >=0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…