Skip to content

← Actionable
Medium, CVSS 6.6amended

Dagster Local File Inclusion vulnerability

CVE-2025-51481GHSA-h7x8-jv97-fvvm

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dagster

    Affected
    < 1.10.16
    Fixed in
    1.10.16
  • PyPI dagster-ge

    Affected
    <= 1.10.14
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
EPSS
  • CVE-2025-51481: 0.62% estimated exploitation activity in the next 30 days; percentile 49.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Local File Inclusion in dagster.grpc.impl.getnotebookdata in Dagster 1.10.14 allows attackers with access to the gRPC server to read arbitrary files by supplying path traversal sequences in the notebookpath field of ExternalNotebookData requests, bypassing the intended extension-based check.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record PYSEC-2025-102

  2. Revision 4 · amended ·

    Amended from osv record PYSEC-2025-102

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-h7x8-jv97-fvvm

  4. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-102

  5. Revision 1 · created ·

    Published from osv record GHSA-h7x8-jv97-fvvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-51481

Advisory: Dagster Local File Inclusion vulnerability
IDs: CVE-2025-51481, GHSA-h7x8-jv97-fvvm
Record: https://patchnext.com/advisories/cve-2025-51481 (revision 5, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: dagster 1.10.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dagster: affected < 1.10.16; fixed in 1.10.16
- PyPI dagster-ge: affected <= 1.10.14

## Suggested inspection (read-only)
- `python -m pip show dagster`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show dagster-ge`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dagster, dagster-ge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h7x8-jv97-fvvm (OSV record GHSA-h7x8-jv97-fvvm lists affected ranges: PyPI dagster >=0 <1.10.16 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-102 (OSV record PYSEC-2025-102 lists affected ranges: PyPI dagster-ge >=0 <=1.10.14)
- Verified: https://github.com/advisories/GHSA-h7x8-jv97-fvvm (GitHub-reviewed advisory GHSA-h7x8-jv97-fvvm lists affected ranges: PyPI dagster >=0 <1.10.16)

Commands are suggestions: review each one before running it.

Loading voting…