Eclipse Jetty affected by MadeYouReset HTTP/2 vulnerability
CVE-2025-5115GHSA-mmxm-8w33-wc4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty.http2:jetty-http2-common 12.1.0.beta3, 12.0.25; org.eclipse.jetty.http2:http2-common 11.0.26, 10.0.26, 9.4.58), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty.http2:jetty-http2-common
- Affected
- >= 12.0.0, <= 12.0.24>= 12.1.0.alpha0, <= 12.1.0.beta2
- Fixed in
- 12.0.25, 12.1.0.beta3
Maven org.eclipse.jetty.http2:http2-common
- Affected
- >= 9.3.0, <= 9.4.57>= 10.0.0, <= 10.0.25>= 11.0.0, <= 11.0.25
- Fixed in
- 10.0.26, 9.4.58, 11.0.26
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmxm-8w33-wc4h lists affected ranges: Maven org.eclipse.jetty.http2:http2-common >=9.3.0 =10.0.0 =11.0.0 =12.0.0 =12.1.0.alpha0 <=12.1.0.beta2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2025-5115: 3.57% estimated exploitation activity in the next 30 days; percentile 89.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Technical Details Below is a technical explanation of a newly discovered vulnerability in HTTP/2, which we refer to as “MadeYouReset.” MadeYouReset Vulnerability Summary The MadeYouReset DDoS vulnerability is a logical vulnerability in the HTTP/2 protocol, that uses malformed HTTP/2 control frames in order to break the max concurrent streams limit - which results in resource exhaustion and distributed denial of service. Mechanism The vulnerability uses malformed HTTP/2 control frames, or malformed flow, in order to make the server reset streams created by the client (using the RSTSTREAM frame). The vulnerability could be triggered by several primitives, defined by the RFC of HTTP/2 (RFC 9113). The Primitives are: 1. WINDOWUPDATE frame with an increment of 0 or an increment that makes the window exceed 2^31 - 1. (section 6.9 + 6.9.1) 2. HEADERS or DATA frames sent on a half-closed (remote) stream (which was closed using the ENDSTREAM flag). (note that for some implementations it's…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mmxm-8w33-wc4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-5115 Advisory: Eclipse Jetty affected by MadeYouReset HTTP/2 vulnerability IDs: CVE-2025-5115, GHSA-mmxm-8w33-wc4h Record: https://patchnext.com/advisories/cve-2025-5115 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty.http2:jetty-http2-common 12.1.0.beta3, 12.0.25; org.eclipse.jetty.http2:http2-common 11.0.26, 10.0.26, 9.4.58. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty.http2:jetty-http2-common: affected >= 12.0.0, <= 12.0.24; >= 12.1.0.alpha0, <= 12.1.0.beta2; fixed in 12.0.25, 12.1.0.beta3 - Maven org.eclipse.jetty.http2:http2-common: affected >= 9.3.0, <= 9.4.57; >= 10.0.0, <= 10.0.25; >= 11.0.0, <= 11.0.25; fixed in 10.0.26, 9.4.58, 11.0.26 ## Suggested inspection (read-only) - Maven org.eclipse.jetty.http2:jetty-http2-common: check the installed version with your package manager. - Maven org.eclipse.jetty.http2:http2-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty.http2:jetty-http2-common, org.eclipse.jetty.http2:http2-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mmxm-8w33-wc4h (GitHub-reviewed advisory GHSA-mmxm-8w33-wc4h lists affected ranges: Maven org.eclipse.jetty.http2:http2-common >=9.3.0 =10.0.0 =11.0.0 =12.0.0 =12.1.0.alpha0 <=12.1.0.beta2) Commands are suggestions: review each one before running it.
Loading voting…