Skip to content

← Actionable
Critical, CVSS 9.3amended

Flowise is vulnerable to stored XSS via "View Messages" allows credential theft in FlowiseAI admin panel

CVE-2025-50538GHSA-964p-j4gg-mhwc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    < 3.0.8
    Fixed in
    3.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2025-50538: 14.71% estimated exploitation activity in the next 30 days; percentile 96.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored Cross-Site Scripting (XSS) vulnerability in FlowiseAI allows a user to inject arbitrary JavaScript code via message input. When an administrator views messages using the "View Messages" button in the workflow UI, the malicious script executes in the context of the admin’s browser, enabling credential theft via access to localStorage. --- Details The vulnerability stems from a lack of input sanitization when displaying stored user messages in the admin interface. A specially crafted payload using <iframe srcdoc="..." can include arbitrary JavaScript, which is executed when the message is rendered. --- PoC 1. Deploy a FlowiseAI agent and make it accessible via browser (e.g., embed on a website). 2. Send the following payload via the agent's chat interface: 3. As an admin, go to the workflow and click "View Messages". 4. The JavaScript is executed in the admin's browser, exfiltrating localStorage content to the attacker-controlled webhook endpoint. --- Impact - Type:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-964p-j4gg-mhwc

  2. Revision 1 · created ·

    Published from osv record GHSA-964p-j4gg-mhwc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-50538

Advisory: Flowise is vulnerable to stored XSS via "View Messages" allows credential theft in FlowiseAI admin panel
IDs: CVE-2025-50538, GHSA-964p-j4gg-mhwc
Record: https://patchnext.com/advisories/cve-2025-50538 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected < 3.0.8; fixed in 3.0.8

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-964p-j4gg-mhwc (OSV record GHSA-964p-j4gg-mhwc lists affected ranges: npm flowise >=0 <3.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-964p-j4gg-mhwc (GitHub-reviewed advisory GHSA-964p-j4gg-mhwc lists affected ranges: npm flowise >=0 <3.0.8)

Commands are suggestions: review each one before running it.

Loading voting…