Skip to content

← Actionable
High, CVSS 7.5amended

Next.JS vulnerability can lead to DoS via cache poisoning

CVE-2025-49826GHSA-67rr-84xm-4c7r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 15.1.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.0.4-canary.51, < 15.1.8
    Fixed in
    15.1.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-49826: 1.13% estimated exploitation activity in the next 30 days; percentile 66.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability affecting Next.js has been addressed. It impacted versions 15.0.4 through 15.1.8 and involved a cache poisoning bug leading to a Denial of Service (DoS) condition. Under certain conditions, this issue may allow a HTTP 204 response to be cached for static pages, leading to the 204 response being served to all users attempting to access the page More details: CVE-2025-49826 Credits - Allam Rachid zhero; - Allam Yasser (inzo)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-67rr-84xm-4c7r

  2. Revision 1 · created ·

    Published from osv record GHSA-67rr-84xm-4c7r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49826

Advisory: Next.JS vulnerability can lead to DoS via cache poisoning
IDs: CVE-2025-49826, GHSA-67rr-84xm-4c7r
Record: https://patchnext.com/advisories/cve-2025-49826 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 15.1.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.0.4-canary.51, < 15.1.8; fixed in 15.1.8

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-67rr-84xm-4c7r (OSV record GHSA-67rr-84xm-4c7r lists affected ranges: npm next >=15.0.4-canary.51 <15.1.8 (fixed))
- Verified: https://github.com/advisories/GHSA-67rr-84xm-4c7r (GitHub-reviewed advisory GHSA-67rr-84xm-4c7r lists affected ranges: npm next >=15.0.4-canary.51 <15.1.8)

Commands are suggestions: review each one before running it.

Loading voting…