Skip to content

← Actionable
Critical, CVSS 9.8

Teleport allows remote authentication bypass

CVE-2025-49825GHSA-8cqv-pj7f-pwpc

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/gravitational/teleport

    Affected
    >= 17.0.0, < 17.5.2>= 16.0.0, < 16.5.12>= 15.0.0, < 15.5.3>= 14.0.0, < 14.4.1>= 13.0.0, < 13.4.27>= 0.0.11, < 12.4.35<= 0.0.0-20250616162021-79b2f26125a1
    Fixed in
    16.5.12, 13.4.27, 17.5.2, 15.5.3, 12.4.35, 14.4.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-8cqv-pj7f-pwpc lists affected ranges: Go github.com/gravitational/teleport >=17.0.0 =16.0.0 =15.0.0 =14.0.0 =13.0.0 =0.0.11 =0 <=0.0.0-20250616162021-79b2f26125a1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-49825: 7.92% estimated exploitation activity in the next 30 days; percentile 94.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A full technical disclosure and open-source patch will be published after the embargo period, ending on June 30th, to allow all users to upgrade. Teleport security engineers identified a critical security vulnerability that could allow remote authentication bypass of Teleport. Teleport Cloud Infrastructure and CI/CD build, test, and release infrastructure aren’t affected. For the full mitigation, upgrade both Proxy and Teleport agents. It is strongly recommend updating clients to the released patch versions as a precaution. Have questions? - OSS Community: opensource@goteleport.com - Legal: legal@goteleport.com - Security: security@goteleport.com - Customer Support: goteleport.com/support - Media Inquiries: teleport@babelpr.com Patches Fixed in versions: 17.5.2, 16.5.12, 15.5.3, 14.4.1, 13.4.27, 12.4.35. These patches are available only on the official Teleport distribution channels. These versions are designated as Critical Security Exception Versions. For these specific…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8cqv-pj7f-pwpc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49825

Advisory: Teleport allows remote authentication bypass
IDs: CVE-2025-49825, GHSA-8cqv-pj7f-pwpc
Record: https://patchnext.com/advisories/cve-2025-49825 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/gravitational/teleport 17.5.2, 16.5.12, 15.5.3, 14.4.1, 13.4.27, 12.4.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/gravitational/teleport: affected >= 17.0.0, < 17.5.2; >= 16.0.0, < 16.5.12; >= 15.0.0, < 15.5.3; >= 14.0.0, < 14.4.1; >= 13.0.0, < 13.4.27; >= 0.0.11, < 12.4.35; <= 0.0.0-20250616162021-79b2f26125a1; fixed in 16.5.12, 13.4.27, 17.5.2, 15.5.3, 12.4.35, 14.4.1

## Suggested inspection (read-only)
- Go github.com/gravitational/teleport: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/gravitational/teleport.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8cqv-pj7f-pwpc (GitHub-reviewed advisory GHSA-8cqv-pj7f-pwpc lists affected ranges: Go github.com/gravitational/teleport >=17.0.0 =16.0.0 =15.0.0 =14.0.0 =13.0.0 =0.0.11 =0 <=0.0.0-20250616162021-79b2f26125a1)

Commands are suggestions: review each one before running it.

Loading voting…