handcraftedinthealps/goodby-csv has Potential Gadget Chain allowing Remote Code Execution
CVE-2025-49597GHSA-x3c7-22c8-prg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (handcraftedinthealps/goodby-csv 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist handcraftedinthealps/goodby-csv
- Affected
- < 1.4.3
- Fixed in
- 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x3c7-22c8-prg7 lists affected ranges: Packagist handcraftedinthealps/goodby-csv >=0 <1.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.9 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-49597: 0.25% estimated exploitation activity in the next 30 days; percentile 16.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact goodby-csv could be used as part of a chain of methods that is exploitable when an insecure deserialization vulnerability exists in an application. This so-called "gadget chain" presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability. Patches Has the problem been patched? What versions should users upgrade to? The problem is patched with Version 1.4.3 Workarounds Patch src/Goodby/CSV/Export/Standard/Collection /CallbackCollection.php: However, this is not directly exploitable; a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize(). There are no such known exploits in goodby-csv. References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x3c7-22c8-prg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-49597 Advisory: handcraftedinthealps/goodby-csv has Potential Gadget Chain allowing Remote Code Execution IDs: CVE-2025-49597, GHSA-x3c7-22c8-prg7 Record: https://patchnext.com/advisories/cve-2025-49597 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: handcraftedinthealps/goodby-csv 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist handcraftedinthealps/goodby-csv: affected < 1.4.3; fixed in 1.4.3 ## Suggested inspection (read-only) - Packagist handcraftedinthealps/goodby-csv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on handcraftedinthealps/goodby-csv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x3c7-22c8-prg7 (GitHub-reviewed advisory GHSA-x3c7-22c8-prg7 lists affected ranges: Packagist handcraftedinthealps/goodby-csv >=0 <1.4.3) Commands are suggestions: review each one before running it.
Loading voting…