Skip to content

← Actionable
Medium, CVSS 4.6amended

n8n allows open redirects via the /signin endpoint

CVE-2025-49592GHSA-5vj6-wjr7-5v9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.98.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    <= 1.97.0
    Fixed in
    1.98.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-49592: 0.23% estimated exploitation activity in the next 30 days; percentile 14.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is an Open Redirect (CWE-601) vulnerability in the login flow of n8n. Authenticated users can be redirected to untrusted, attacker-controlled domains after logging in, by crafting malicious URLs with a misleading redirect query parameter. This may lead to: - Phishing attacks by impersonating the n8n UI on lookalike domains (e.g., n8n.local.evil.com) - Credential or 2FA theft if users are tricked into re-entering sensitive information - Reputation risk due to the visual similarity between attacker-controlled domains and trusted ones The vulnerability affects anyone hosting n8n and exposing the /signin endpoint to users. Patches The issue has been patched in 1.98.0. All users should upgrade to this version or later. The fix introduces strict origin validation for redirect URLs, ensuring only same-origin or relative paths are allowed after login. Patch commit: https://github.com/n8n-io/n8n/pull/16034

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5vj6-wjr7-5v9f

  2. Revision 1 · created ·

    Published from osv record GHSA-5vj6-wjr7-5v9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49592

Advisory: n8n allows open redirects via the /signin endpoint
IDs: CVE-2025-49592, GHSA-5vj6-wjr7-5v9f
Record: https://patchnext.com/advisories/cve-2025-49592 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.98.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected <= 1.97.0; fixed in 1.98.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5vj6-wjr7-5v9f (OSV record GHSA-5vj6-wjr7-5v9f lists affected ranges: npm n8n >=0 <1.98.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5vj6-wjr7-5v9f (GitHub-reviewed advisory GHSA-5vj6-wjr7-5v9f lists affected ranges: npm n8n >=0 <=1.97.0)

Commands are suggestions: review each one before running it.

Loading voting…