Citizen skin vulnerable to stored XSS through multiple system messages
CVE-2025-49575GHSA-4c2h-67qq-vm87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (starcitizentools/citizen-skin 3.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist starcitizentools/citizen-skin
- Affected
- >= 2.4.2, < 3.3.1
- Fixed in
- 3.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c2h-67qq-vm87 lists affected ranges: Packagist starcitizentools/citizen-skin >=2.4.2 <3.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-49575: 0.43% estimated exploitation activity in the next 30 days; percentile 36.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple system messages are inserted into the CommandPaletteFooter as raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM. Details The messages are retrieved using the plain() output mode: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L61-L66 currentTip is set to one of these messages: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L69 currentTip is inserted as raw HTML (vue/no-v-html should not be ignored here): https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L3-L4 PoC 1. Edit citizen-command-palette-tip-commands,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4c2h-67qq-vm87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-49575 Advisory: Citizen skin vulnerable to stored XSS through multiple system messages IDs: CVE-2025-49575, GHSA-4c2h-67qq-vm87 Record: https://patchnext.com/advisories/cve-2025-49575 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: starcitizentools/citizen-skin 3.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist starcitizentools/citizen-skin: affected >= 2.4.2, < 3.3.1; fixed in 3.3.1 ## Suggested inspection (read-only) - Packagist starcitizentools/citizen-skin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on starcitizentools/citizen-skin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4c2h-67qq-vm87 (GitHub-reviewed advisory GHSA-4c2h-67qq-vm87 lists affected ranges: Packagist starcitizentools/citizen-skin >=2.4.2 <3.3.1) Commands are suggestions: review each one before running it.
Loading voting…