Skip to content

← Actionable
Medium, CVSS 6.0amended

Nautobot vulnerable to secrets exposure and data manipulation through Jinja2 templating

CVE-2025-49142GHSA-wjw6-95h5-4jpx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nautobot 2.4.10, 1.6.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nautobot

    Affected
    < 1.6.32>= 2.0.0, < 2.4.10
    Fixed in
    1.6.32, 2.4.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2025-49142: 0.37% estimated exploitation activity in the next 30 days; percentile 31.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? All users of Nautobot versions prior to 2.4.10 or prior to 1.6.32 are potentially affected. Due to insufficient security configuration of the Jinja2 templating feature used in computed fields, custom links, etc. in Nautobot: 1. A malicious user could configure this feature set in ways that could expose the value of Secrets defined in Nautobot when the templated content is rendered. 2. A malicious user could configure this feature set in ways that could call Python APIs to modify data within Nautobot when the templated content is rendered, bypassing the object permissions assigned to the viewing user. Patches Has the problem been patched? What versions should users upgrade to? Nautobot versions 1.6.32 and 2.4.10 will include fixes for the vulnerability. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The vulnerability can be partially mitigated by configuring object permissions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wjw6-95h5-4jpx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wjw6-95h5-4jpx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49142

Advisory: Nautobot vulnerable to secrets exposure and data manipulation through Jinja2 templating
IDs: CVE-2025-49142, GHSA-wjw6-95h5-4jpx
Record: https://patchnext.com/advisories/cve-2025-49142 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nautobot 2.4.10, 1.6.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nautobot: affected < 1.6.32; >= 2.0.0, < 2.4.10; fixed in 1.6.32, 2.4.10

## Suggested inspection (read-only)
- `python -m pip show nautobot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nautobot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wjw6-95h5-4jpx (OSV record GHSA-wjw6-95h5-4jpx lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.4.10 (fixed))
- Verified: https://github.com/advisories/GHSA-wjw6-95h5-4jpx (GitHub-reviewed advisory GHSA-wjw6-95h5-4jpx lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.4.10)

Commands are suggestions: review each one before running it.

Loading voting…