HaxCMS-PHP Command Injection Vulnerability
CVE-2025-49141GHSA-g4cf-pp4x-hqgw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 11.0.3
- Fixed in
- 11.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g4cf-pp4x-hqgw lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4cf-pp4x-hqgw lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-49141: 1.49% estimated exploitation activity in the next 30 days; percentile 74.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The 'gitImportSite' functionality obtains a URL string from a POST request and insufficiently validates user input. The ’setremote’ function later passes this input into ’procopen’, yielding OS command injection. Details The vulnerability exists in the logic of the ’gitImportSite’ function, located in ’Operations.php’. The current implementation only relies on the ’filtervar’ and 'strpos' functions to validate the URL, which is not sufficient to ensure absence of all Bash special characters used for command injection. Affected Resources • Operations.php:2103 gitImportSite() • \<domain\/\<user\/system/api/gitImportSite PoC To replicate this vulnerability, authenticate and send a POST request to the 'gitImportSite' endpoint with a crafted URL in the JSON data. Note, a valid token needs to be obtained by capturing a request to another API endpoint (such as 'archiveSite'). 1. Start a webserver. 2. Initiate a request to the ’archiveSite’ endpoint. 3. Capture and modify the request…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g4cf-pp4x-hqgw
- Revision 1 · created ·
Published from osv record GHSA-g4cf-pp4x-hqgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-49141 Advisory: HaxCMS-PHP Command Injection Vulnerability IDs: CVE-2025-49141, GHSA-g4cf-pp4x-hqgw Record: https://patchnext.com/advisories/cve-2025-49141 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @haxtheweb/haxcms-nodejs: affected < 11.0.3; fixed in 11.0.3 ## Suggested inspection (read-only) - `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @haxtheweb/haxcms-nodejs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g4cf-pp4x-hqgw (OSV record GHSA-g4cf-pp4x-hqgw lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-g4cf-pp4x-hqgw (GitHub-reviewed advisory GHSA-g4cf-pp4x-hqgw lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.3) Commands are suggestions: review each one before running it.
Loading voting…