Skip to content

← Actionable
High, CVSS 7.5

Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)

CVE-2025-49140GHSA-f26w-gh5m-qq77

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pion/interceptor 0.1.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-49140: 0.49% estimated exploitation activity in the next 30 days; percentile 42.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Pion Interceptor versions v0.1.36 through v0.1.38 contain a bug in a RTP packet factory that can be exploited to trigger a panic with Pion based SFU via crafted RTP packets, This only affect users that use pion/interceptor. Patches Upgrade to v0.1.39 or later, which includes PR #338 which validates that: padLen 0 && padLen <= payloadLength and return error on overflow, avoiding panic. If upgrading is not possible, apply the patch from the pull request manually or drop packets whose P-bit is set but whose padLen is zero or larger than the remaining payload. Workarounds At the application layer, reject any RTP packet where: before passing it to Pion’s packet factories. References Commit fixing the bug: https://github.com/pion/interceptor/commit/fa5b35ea867389cec33a9c82fffbd459ca8958e5 Pull request: https://github.com/pion/interceptor/pull/338 Issue: https://github.com/pion/webrtc/issues/3148

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f26w-gh5m-qq77

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49140

Advisory: Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)
IDs: CVE-2025-49140, GHSA-f26w-gh5m-qq77
Record: https://patchnext.com/advisories/cve-2025-49140 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pion/interceptor 0.1.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pion/interceptor: affected >= 0.1.36, < 0.1.39; fixed in 0.1.39

## Suggested inspection (read-only)
- Go github.com/pion/interceptor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pion/interceptor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f26w-gh5m-qq77 (GitHub-reviewed advisory GHSA-f26w-gh5m-qq77 lists affected ranges: Go github.com/pion/interceptor >=0.1.36 <0.1.39)

Commands are suggestions: review each one before running it.

Loading voting…