Skip to content

← Actionable
Medium, CVSS 5.3amended

@haxtheweb/haxcms-nodejs Iframe Phishing vulnerability

CVE-2025-49139GHSA-v3ph-2q5q-cg88

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 11.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-49139: 0.37% estimated exploitation activity in the next 30 days; percentile 30.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL. Affected Resources - Operations.php:868 - https://<site/<user/system/api/saveNode PoC 1. Set the URL in an iframe pointing to an attacker-controlled server running Responder 2. Once another user visits the site, they are prompted to sign in. 3. If a user inputs credentials, the username and password hash are outputted in Responder. Impact An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v3ph-2q5q-cg88

  2. Revision 1 · created ·

    Published from osv record GHSA-v3ph-2q5q-cg88

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49139

Advisory: @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability
IDs: CVE-2025-49139, GHSA-v3ph-2q5q-cg88
Record: https://patchnext.com/advisories/cve-2025-49139 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 11.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/haxcms-nodejs: affected < 11.0.0; fixed in 11.0.0

## Suggested inspection (read-only)
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/haxcms-nodejs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3ph-2q5q-cg88 (OSV record GHSA-v3ph-2q5q-cg88 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v3ph-2q5q-cg88 (GitHub-reviewed advisory GHSA-v3ph-2q5q-cg88 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <11.0.0)

Commands are suggestions: review each one before running it.

Loading voting…