Skip to content

← Actionable
Medium, CVSS 6.5

HAX CMS vulnerable to Local File Inclusion via saveOutline API Location Parameter

CVE-2025-49138GHSA-hxrr-x32w-cg8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elmsln/haxcms 11.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-49138: 0.52% estimated exploitation activity in the next 30 days; percentile 44.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated Local File Inclusion (LFI) vulnerability in the HAXCMS saveOutline endpoint allows a low-privileged user to read arbitrary files on the server by manipulating the location field written into site.json. This enables attackers to exfiltrate sensitive system files such as /etc/passwd, application secrets, or configuration files accessible to the web server (www-data). Details The vulnerability stems from the way the HAXCMS backend handles the location field in the site's outline. When a user sends a POST request to /system/api/saveOutline, the backend stores the provided location value directly into the site.json file associated with the site, without validating or sanitizing the input. Later the location parameter is interpreted by the CMS like in HAXCMSSite.php line 1248 to resolve and load the content for a given node. If the location field contains a relative path like ../../../etc/passwd, the application will attempt to read and render that file. PoC 1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hxrr-x32w-cg8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49138

Advisory: HAX CMS vulnerable to Local File Inclusion via saveOutline API Location Parameter
IDs: CVE-2025-49138, GHSA-hxrr-x32w-cg8g
Record: https://patchnext.com/advisories/cve-2025-49138 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elmsln/haxcms 11.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist elmsln/haxcms: affected < 11.0.0; fixed in 11.0.0

## Suggested inspection (read-only)
- Packagist elmsln/haxcms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elmsln/haxcms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hxrr-x32w-cg8g (GitHub-reviewed advisory GHSA-hxrr-x32w-cg8g lists affected ranges: Packagist elmsln/haxcms >=0 <11.0.0)

Commands are suggestions: review each one before running it.

Loading voting…