Hax CMS Stored Cross-Site Scripting vulnerability
CVE-2025-49137GHSA-2vc4-3hx7-v7v7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (elmsln/haxcms 11.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist elmsln/haxcms
- Affected
- < 11.0.0
- Fixed in
- 11.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2vc4-3hx7-v7v7 lists affected ranges: Packagist elmsln/haxcms >=0 <11.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2025-49137: 0.27% estimated exploitation activity in the next 30 days; percentile 19.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The application does not sufficiently sanitize user input, allowing for the execution of arbitrary JavaScript code. The 'saveNode' and 'saveManifest' endpoints take user input and store it in the JSON schema for the site. This content is then rendered in the generated HAX site. Although the application does not allow users to supply a 'script' tag, it does allow the use of other HTML tags to run JavaScript. Affected Resources - Operations.php:258 saveManifest() - Operations.php:868 saveNode() - https://<site/<user/system/api/saveNode - https://<site/<user/system/api/saveManifest Impact An authenticated attacker can use the site editor and settings editor to store malicious payloads in a HAX site which execute arbitrary JavaScript when a user visits the site. This can be used to steal a user's session cookie or other sensitive data. PoCs saveNode To replicate this vulnerability, an attacker can use the "View Source" functionality within the site editor to enter a malicious…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2vc4-3hx7-v7v7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-49137 Advisory: Hax CMS Stored Cross-Site Scripting vulnerability IDs: CVE-2025-49137, GHSA-2vc4-3hx7-v7v7 Record: https://patchnext.com/advisories/cve-2025-49137 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: elmsln/haxcms 11.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist elmsln/haxcms: affected < 11.0.0; fixed in 11.0.0 ## Suggested inspection (read-only) - Packagist elmsln/haxcms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on elmsln/haxcms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2vc4-3hx7-v7v7 (GitHub-reviewed advisory GHSA-2vc4-3hx7-v7v7 lists affected ranges: Packagist elmsln/haxcms >=0 <11.0.0) Commands are suggestions: review each one before running it.
Loading voting…