Skip to content

← Actionable
Critical, CVSS 10.0

Pterodactyl Panel Allows Unauthenticated Arbitrary Remote Code Execution

CVE-2025-49132GHSA-24wv-6c99-f843

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.11.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-49132: 54.46% estimated exploitation activity in the next 30 days; percentile 99.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Using the /locales/locale.json with the locale and namespace query parameters, a malicious actor is able to execute arbitrary code, without being authenticated. With the ability to execute arbitrary code, this vulnerability can be exploited in an infinite number of ways. It could be used to gain access to the Panel's server, read credentials from the Panel's config (.env or otherwise), extract sensitive information from the database (such as user details [username, email, first and last name, hashed password, ip addresses, etc]), access files of servers managed by the panel, etc. Patches This vulnerability was patched by https://github.com/pterodactyl/panel/commit/24c82b0e335fb5d7a844226b08abf9f176e592f0 and was released under the v1.11.11 tag without any other code modifications compared to v1.11.10. For those who need to patch their installations in-place or apply it on top of other code modifications, a patch file can be retrieved from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-24wv-6c99-f843

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49132

Advisory: Pterodactyl Panel Allows Unauthenticated Arbitrary Remote Code Execution
IDs: CVE-2025-49132, GHSA-24wv-6c99-f843
Record: https://patchnext.com/advisories/cve-2025-49132 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.11.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected <= 1.11.10; fixed in 1.11.11

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24wv-6c99-f843 (GitHub-reviewed advisory GHSA-24wv-6c99-f843 lists affected ranges: Packagist pterodactyl/panel >=0 <=1.11.10)

Commands are suggestions: review each one before running it.

Loading voting…