Apache Tomcat - Security constraint bypass for pre/post-resources
CVE-2025-49125GHSA-wc4r-xq3c-5cf3
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 11.0.0-M1, <= 11.0.7>= 10.1.0-M1, <= 10.1.41>= 9.0.0.M1, <= 9.0.105>= 8.5.0, <= 8.5.100
- Fixed in
- 9.0.106, 10.1.42, 11.0.8
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, <= 11.0.7>= 10.1.0-M1, <= 10.1.41>= 9.0.0.M1, <= 9.0.105>= 8.5.0, <= 8.5.100
- Fixed in
- 9.0.106, 10.1.42, 11.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wc4r-xq3c-5cf3 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-49125: 3.44% estimated exploitation activity in the next 30 days; percentile 88.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wc4r-xq3c-5cf3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-49125 Advisory: Apache Tomcat - Security constraint bypass for pre/post-resources IDs: CVE-2025-49125, GHSA-wc4r-xq3c-5cf3 Record: https://patchnext.com/advisories/cve-2025-49125 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.8, 10.1.42, 9.0.106; org.apache.tomcat.embed:tomcat-embed-core 11.0.8, 10.1.42, 9.0.106. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, <= 11.0.7; >= 10.1.0-M1, <= 10.1.41; >= 9.0.0.M1, <= 9.0.105; >= 8.5.0, <= 8.5.100; fixed in 9.0.106, 10.1.42, 11.0.8 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, <= 11.0.7; >= 10.1.0-M1, <= 10.1.41; >= 9.0.0.M1, <= 9.0.105; >= 8.5.0, <= 8.5.100; fixed in 9.0.106, 10.1.42, 11.0.8 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wc4r-xq3c-5cf3 (GitHub-reviewed advisory GHSA-wc4r-xq3c-5cf3 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100) Commands are suggestions: review each one before running it.
Loading voting…