Skip to content

← Actionable
Critical, CVSS 9.9Exploited · CISA KEV

Roundcube Webmail Vulnerable to Authenticated RCE via PHP Object Deserialization

CVE-2025-49113GHSA-8j8w-wwqc-x596

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (roundcube/roundcubemail 1.6.11, 1.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-49113: 99.49% estimated exploitation activity in the next 30 days; percentile 99.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8j8w-wwqc-x596

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49113

Advisory: Roundcube Webmail Vulnerable to Authenticated RCE via PHP Object Deserialization
IDs: CVE-2025-49113, GHSA-8j8w-wwqc-x596
Record: https://patchnext.com/advisories/cve-2025-49113 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: roundcube/roundcubemail 1.6.11, 1.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist roundcube/roundcubemail: affected < 1.5.10; >= 1.6.0, < 1.6.11; fixed in 1.5.10, 1.6.11

## Suggested inspection (read-only)
- Packagist roundcube/roundcubemail: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on roundcube/roundcubemail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8j8w-wwqc-x596 (GitHub-reviewed advisory GHSA-8j8w-wwqc-x596 lists affected ranges: Packagist roundcube/roundcubemail >=0 =1.6.0 <1.6.11)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-49113 to the Known Exploited Vulnerabilities catalog on 2026-02-20.)

Commands are suggestions: review each one before running it.

Loading voting…