Skip to content

← Actionable
Low, CVSS 3.7amended

Next.js has a Cache poisoning vulnerability due to omission of the Vary header

CVE-2025-49005GHSA-r2fc-ccr8-96c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 15.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.3.0, < 15.3.3
    Fixed in
    15.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-49005: 0.49% estimated exploitation activity in the next 30 days; percentile 42.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A cache poisoning issue in Next.js App Router =15.3.0 and < 15.3.3 may have allowed RSC payloads to be cached and served in place of HTML, under specific conditions involving middleware and redirects. This issue has been fixed in Next.js 15.3.3. Users on affected versions should upgrade immediately and redeploy to ensure proper caching behavior. More details: CVE-2025-49005

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r2fc-ccr8-96c4

  2. Revision 1 · created ·

    Published from osv record GHSA-r2fc-ccr8-96c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-49005

Advisory: Next.js has a Cache poisoning vulnerability due to omission of the Vary header
IDs: CVE-2025-49005, GHSA-r2fc-ccr8-96c4
Record: https://patchnext.com/advisories/cve-2025-49005 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 15.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.3.0, < 15.3.3; fixed in 15.3.3

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r2fc-ccr8-96c4 (OSV record GHSA-r2fc-ccr8-96c4 lists affected ranges: npm next >=15.3.0 <15.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-r2fc-ccr8-96c4 (GitHub-reviewed advisory GHSA-r2fc-ccr8-96c4 lists affected ranges: npm next >=15.3.0 <15.3.3)

Commands are suggestions: review each one before running it.

Loading voting…