Skip to content

← Actionable
High, CVSS 8.7amended

Multer vulnerable to Denial of Service via unhandled exception

CVE-2025-48997GHSA-g5hg-p3ph-g8qg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (multer 2.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm multer

    Affected
    >= 1.4.4-lts.1, < 2.0.1
    Fixed in
    2.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-48997: 0.48% estimated exploitation activity in the next 30 days; percentile 41.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in Multer versions =1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Patches Users should upgrade to 2.0.1 Workarounds None References https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 https://github.com/expressjs/multer/issues/1233 https://github.com/expressjs/multer/pull/1256

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g5hg-p3ph-g8qg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g5hg-p3ph-g8qg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48997

Advisory: Multer vulnerable to Denial of Service via unhandled exception
IDs: CVE-2025-48997, GHSA-g5hg-p3ph-g8qg
Record: https://patchnext.com/advisories/cve-2025-48997 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: multer 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm multer: affected >= 1.4.4-lts.1, < 2.0.1; fixed in 2.0.1

## Suggested inspection (read-only)
- `npm ls multer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on multer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5hg-p3ph-g8qg (OSV record GHSA-g5hg-p3ph-g8qg lists affected ranges: npm multer >=1.4.4-lts.1 <2.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g5hg-p3ph-g8qg (GitHub-reviewed advisory GHSA-g5hg-p3ph-g8qg lists affected ranges: npm multer >=1.4.4-lts.1 <2.0.1)

Commands are suggestions: review each one before running it.

Loading voting…