vllm API endpoints vulnerable to Denial of Service Attacks
CVE-2025-48956GHSA-rxc4-3w6r-4v47
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.10.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.1.0, < 0.10.1.1
- Fixed in
- 0.10.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rxc4-3w6r-4v47 lists affected ranges: PyPI vllm >=0.1.0 <0.10.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rxc4-3w6r-4v47 lists affected ranges: PyPI vllm >=0.1.0 <0.10.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-48956: 0.56% estimated exploitation activity in the next 30 days; percentile 46.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. Details The vulnerability leverages the abuse of HTTP headers. By setting a header such as X-Forwarded-For to a very large value like ("A" 5800000000), the server's HTTP parser or application logic may attempt to load the entire request into memory, overwhelming system resources. Impact What kind of vulnerability is it? Who is impacted? Type of vulnerability: Denial of Service (DoS) Resolution Upgrade to a version of vLLM that includes appropriate HTTP limits by deafult, or use a proxy in front of vLLM which provides protection against this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rxc4-3w6r-4v47
- Revision 1 · created ·
Published from osv record GHSA-rxc4-3w6r-4v47
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48956 Advisory: vllm API endpoints vulnerable to Denial of Service Attacks IDs: CVE-2025-48956, GHSA-rxc4-3w6r-4v47 Record: https://patchnext.com/advisories/cve-2025-48956 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.10.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.1.0, < 0.10.1.1; fixed in 0.10.1.1 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rxc4-3w6r-4v47 (OSV record GHSA-rxc4-3w6r-4v47 lists affected ranges: PyPI vllm >=0.1.0 <0.10.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rxc4-3w6r-4v47 (GitHub-reviewed advisory GHSA-rxc4-3w6r-4v47 lists affected ranges: PyPI vllm >=0.1.0 <0.10.1.1) Commands are suggestions: review each one before running it.
Loading voting…