Auth0-PHP SDK Deserialization of Untrusted Data vulnerability
CVE-2025-48951GHSA-v9m8-9xxp-q492
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/auth0-php 8.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/auth0-php
- Affected
- >= 8.0.0-BETA3, < 8.3.1
- Fixed in
- 8.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9m8-9xxp-q492 lists affected ranges: Packagist auth0/auth0-php >=8.0.0-BETA3 <8.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-48951: 0.75% estimated exploitation activity in the next 30 days; percentile 55.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview The Auth0 PHP SDK contains a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0-PHP SDK, versions between 8.0.0-BETA3 to 8.3.0. 2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between 8.0.0-BETA3 to 8.3.0: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress. Fix Upgrade Auth0/Auth0-PHP to 8.3.1. Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v9m8-9xxp-q492
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48951 Advisory: Auth0-PHP SDK Deserialization of Untrusted Data vulnerability IDs: CVE-2025-48951, GHSA-v9m8-9xxp-q492 Record: https://patchnext.com/advisories/cve-2025-48951 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/auth0-php 8.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/auth0-php: affected >= 8.0.0-BETA3, < 8.3.1; fixed in 8.3.1 ## Suggested inspection (read-only) - Packagist auth0/auth0-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/auth0-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v9m8-9xxp-q492 (GitHub-reviewed advisory GHSA-v9m8-9xxp-q492 lists affected ranges: Packagist auth0/auth0-php >=8.0.0-BETA3 <8.3.1) Commands are suggestions: review each one before running it.
Loading voting…