Skip to content

← Actionable
High, CVSS 8.9

Navidrome allows SQL Injection via role parameter

CVE-2025-48949GHSA-5wgp-vjxm-3x2r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/navidrome/navidrome 0.56.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 Β· CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P Β· score source
EPSS
  • CVE-2025-48949: 0.51% estimated exploitation activity in the next 30 days; percentile 43.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

πŸ›‘ Security Advisory: SQL Injection Vulnerability in Navidrome v0.55.2 Overview This vulnerability arises due to improper input validation on the role parameter within the API endpoint /api/artist. Attackers can exploit this flaw to inject arbitrary SQL queries, potentially gaining unauthorized access to the backend database and compromising sensitive user information. --- Details Vulnerable Component: API endpoint β†’ /api/artist Parameter β†’ role Vulnerability Type: SQL Injection (stacked queries, UNION queries) Database Affected: SQLite (confirmed exploitation via SQLite-specific payloads) Impact: Successful exploitation allows an unauthenticated attacker to: Execute arbitrary SQL commands Extract or manipulate sensitive data (e.g., user records, playlists) Potentially escalate privileges or disrupt service availability --- Proof of Concept (PoC) Example Exploit Command: Sample Payloads: Stacked Queries: UNION-Based Query: Example HTTP Request: ---

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 Β· created Β·

    Published from ghsa record GHSA-5wgp-vjxm-3x2r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48949

Advisory: Navidrome allows SQL Injection via role parameter
IDs: CVE-2025-48949, GHSA-5wgp-vjxm-3x2r
Record: https://patchnext.com/advisories/cve-2025-48949 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/navidrome/navidrome 0.56.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/navidrome/navidrome: affected >= 0.55.0, <= 0.55.2; fixed in 0.56.0

## Suggested inspection (read-only)
- Go github.com/navidrome/navidrome: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/navidrome/navidrome.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5wgp-vjxm-3x2r (GitHub-reviewed advisory GHSA-5wgp-vjxm-3x2r lists affected ranges: Go github.com/navidrome/navidrome >=0.55.0 <=0.55.2)

Commands are suggestions: review each one before running it.

Loading voting…