Navidrome Transcoding Permission Bypass Vulnerability Report
CVE-2025-48948GHSA-f238-rggp-82m3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/navidrome/navidrome 0.56.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/navidrome/navidrome
- Affected
- <= 0.55.2
- Fixed in
- 0.56.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f238-rggp-82m3 lists affected ranges: Go github.com/navidrome/navidrome >=0 <=0.55.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-48948: 0.51% estimated exploitation activity in the next 30 days; percentile 43.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A permission verification flaw in Navidrome allows any authenticated regular user to bypass authorization checks and perform administrator-only transcoding configuration operations, including creating, modifying, and deleting transcoding settings. Details Navidrome supports transcoding functionality which, although disabled by default, should restrict configuration operations to administrators only. However, the application fails to properly validate whether a user has administrative privileges when handling transcoding configuration requests. The vulnerability exists in the API endpoints that manage transcoding settings. When a regular user sends requests to these endpoints, the application processes them without verifying if the user has administrative privileges, despite the JWT token clearly indicating the user is not an administrator ("adm":false). The affected endpoints include: - POST /api/transcoding (Create transcoding configuration) - PUT /api/transcoding/:id…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f238-rggp-82m3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48948 Advisory: Navidrome Transcoding Permission Bypass Vulnerability Report IDs: CVE-2025-48948, GHSA-f238-rggp-82m3 Record: https://patchnext.com/advisories/cve-2025-48948 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/navidrome/navidrome 0.56.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/navidrome/navidrome: affected <= 0.55.2; fixed in 0.56.0 ## Suggested inspection (read-only) - Go github.com/navidrome/navidrome: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/navidrome/navidrome. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f238-rggp-82m3 (GitHub-reviewed advisory GHSA-f238-rggp-82m3 lists affected ranges: Go github.com/navidrome/navidrome >=0 <=0.55.2) Commands are suggestions: review each one before running it.
Loading voting…