Skip to content

← Actionable
Unratedamended

pycares has a Use-After-Free Vulnerability

CVE-2025-48945GHSA-5qpg-rh4j-qp35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycares 4.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pycares

    Affected
    <= 4.8.0
    Fixed in
    4.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2025-48945: 0.48% estimated exploitation activity in the next 30 days; percentile 41.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pycares is vulnerable to a use-after-free condition that occurs when a Channel object is garbage collected while DNS queries are still pending. This results in a fatal Python error and interpreter crash. Details Root Cause The vulnerability stems from improper handling of callback references when the Channel object is destroyed: 1. When a DNS query is initiated, pycares stores a callback reference using ffi.newhandle() 2. If the Channel object is garbage collected while queries are pending, the callback references become invalid 3. When c-ares attempts to invoke the callback, it accesses freed memory, causing a fatal error This issue was much more likely to occur when using eventthread=True but could happen without it under the right circumstances. Technical Details The core issue is a race condition between Python's garbage collector and c-ares's callback execution: 1. When del is called from within a c-ares callback context, we cannot immediately call aresdestroy() because…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5qpg-rh4j-qp35

  2. Revision 1 · created ·

    Published from osv record GHSA-5qpg-rh4j-qp35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48945

Advisory: pycares has a Use-After-Free Vulnerability
IDs: CVE-2025-48945, GHSA-5qpg-rh4j-qp35
Record: https://patchnext.com/advisories/cve-2025-48945 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pycares 4.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pycares: affected <= 4.8.0; fixed in 4.9.0

## Suggested inspection (read-only)
- `python -m pip show pycares`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pycares.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5qpg-rh4j-qp35 (OSV record GHSA-5qpg-rh4j-qp35 lists affected ranges: PyPI pycares >=0 <4.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5qpg-rh4j-qp35 (GitHub-reviewed advisory GHSA-5qpg-rh4j-qp35 lists affected ranges: PyPI pycares >=0 <=4.8.0)

Commands are suggestions: review each one before running it.

Loading voting…