vLLM Tool Schema allows DoS via Malformed pattern and type Fields
CVE-2025-48944GHSA-vrq3-r879-7m65
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.8.0, < 0.9.0
- Fixed in
- 0.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vrq3-r879-7m65 lists affected ranges: PyPI vllm >=0.8.0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vrq3-r879-7m65 lists affected ranges: PyPI vllm >=0.8.0 <0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-48944: 0.64% estimated exploitation activity in the next 30 days; percentile 50.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Details The "type" field is expected to be one of: "string", "number", "object", "boolean", "array", or "null". Supplying any other value will cause the worker to crash with the following error: RuntimeError: [11:03:34] /project/cpp/jsonschemaconverter.cc:637: Unsupported type "somethingornothing" The "pattern" field undergoes Jinja2 rendering (I think) prior to being passed unsafely into the native regex compiler without validation or escaping. This allows malformed expressions to reach the underlying C++ regex engine, resulting in fatal errors. For example, the following inputs will crash the worker: Unclosed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vrq3-r879-7m65
- Revision 1 · created ·
Published from osv record GHSA-vrq3-r879-7m65
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48944 Advisory: vLLM Tool Schema allows DoS via Malformed pattern and type Fields IDs: CVE-2025-48944, GHSA-vrq3-r879-7m65 Record: https://patchnext.com/advisories/cve-2025-48944 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.8.0, < 0.9.0; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vrq3-r879-7m65 (OSV record GHSA-vrq3-r879-7m65 lists affected ranges: PyPI vllm >=0.8.0 <0.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vrq3-r879-7m65 (GitHub-reviewed advisory GHSA-vrq3-r879-7m65 lists affected ranges: PyPI vllm >=0.8.0 <0.9.0) Commands are suggestions: review each one before running it.
Loading voting…