Skip to content

← Actionable
Medium, CVSS 4.2amended

tarteaucitron.js vulnerable to DOM Clobbering via document.currentScript

CVE-2025-48939GHSA-q43x-79jr-cq98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tarteaucitronjs 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:N/I:L/A:L
EPSS
  • CVE-2025-48939: 0.20% estimated exploitation activity in the next 30 days; percentile 10.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was identified in tarteaucitron.js where document.currentScript was accessed without verifying that it referenced an actual <script element. If an attacker injected an HTML element such as: it could clobber the document.currentScript property. This causes the script to resolve incorrectly to an <img element instead of the <script tag, leading to unexpected behavior or failure to load the script path correctly. This issue arises because in some browser environments, named DOM elements (e.g., name="currentScript") become properties on the global document object. Impact An attacker with control over the HTML could exploit this to change the CDN domain of tarteaucitron. Fix https://github.com/AmauriC/tarteaucitron.js/commit/230a3b69d363837acfa895823d841e0608826ba3 The issue was resolved by verifying that document.currentScript is an instance of HTMLScriptElement. If not, the script now falls back safely to the last <script tag on the page.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q43x-79jr-cq98

  2. Revision 1 · created ·

    Published from osv record GHSA-q43x-79jr-cq98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48939

Advisory: tarteaucitron.js vulnerable to DOM Clobbering via document.currentScript
IDs: CVE-2025-48939, GHSA-q43x-79jr-cq98
Record: https://patchnext.com/advisories/cve-2025-48939 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tarteaucitronjs 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tarteaucitronjs: affected < 1.22.0; fixed in 1.22.0

## Suggested inspection (read-only)
- `npm ls tarteaucitronjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tarteaucitronjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q43x-79jr-cq98 (OSV record GHSA-q43x-79jr-cq98 lists affected ranges: npm tarteaucitronjs >=0 <1.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q43x-79jr-cq98 (GitHub-reviewed advisory GHSA-q43x-79jr-cq98 lists affected ranges: npm tarteaucitronjs >=0 <1.22.0)

Commands are suggestions: review each one before running it.

Loading voting…