Skip to content

← Actionable
Medium, CVSS 5.5

Deno has --allow-read / --allow-write permission bypass in node:sqlite

CVE-2025-48935GHSA-8vxj-4cph-c596

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno_node 0.134.0; deno 2.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io deno_node

    Affected
    >= 0.129.0, < 0.134.0
    Fixed in
    0.134.0
  • crates.io deno

    Affected
    >= 2.2.0, < 2.2.5
    Fixed in
    2.2.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-48935: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It is possible to bypass Deno's read/write permission checks by using ATTACH DATABASE statement. PoC

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8vxj-4cph-c596

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48935

Advisory: Deno has --allow-read / --allow-write permission bypass in `node:sqlite`
IDs: CVE-2025-48935, GHSA-8vxj-4cph-c596
Record: https://patchnext.com/advisories/cve-2025-48935 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deno_node 0.134.0; deno 2.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io deno_node: affected >= 0.129.0, < 0.134.0; fixed in 0.134.0
- crates.io deno: affected >= 2.2.0, < 2.2.5; fixed in 2.2.5

## Suggested inspection (read-only)
- crates.io deno_node: check the installed version with your package manager.
- crates.io deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deno_node, deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8vxj-4cph-c596 (GitHub-reviewed advisory GHSA-8vxj-4cph-c596 lists affected ranges: crates.io deno >=2.2.0 =0.129.0 <0.134.0)

Commands are suggestions: review each one before running it.

Loading voting…