Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs
CVE-2025-48924GHSA-j288-q9x7-2f5v
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven commons-lang:commons-lang
- Affected
- >= 2.0, <= 2.6
- Fixed in
- no fixed version recorded
Maven org.apache.commons:commons-lang3
- Affected
- >= 3.0, < 3.18.0
- Fixed in
- 3.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j288-q9x7-2f5v lists affected ranges: Maven org.apache.commons:commons-lang3 >=3.0 =2.0 <=2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-48924: 2.63% estimated exploitation activity in the next 30 days; percentile 85.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j288-q9x7-2f5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48924 Advisory: Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs IDs: CVE-2025-48924, GHSA-j288-q9x7-2f5v Record: https://patchnext.com/advisories/cve-2025-48924 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.commons:commons-lang3 3.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven commons-lang:commons-lang: affected >= 2.0, <= 2.6 - Maven org.apache.commons:commons-lang3: affected >= 3.0, < 3.18.0; fixed in 3.18.0 ## Suggested inspection (read-only) - Maven commons-lang:commons-lang: check the installed version with your package manager. - Maven org.apache.commons:commons-lang3: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on commons-lang:commons-lang, org.apache.commons:commons-lang3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j288-q9x7-2f5v (GitHub-reviewed advisory GHSA-j288-q9x7-2f5v lists affected ranges: Maven org.apache.commons:commons-lang3 >=3.0 =2.0 <=2.6) Commands are suggestions: review each one before running it.
Loading voting…