Skip to content

← Actionable
Medium, CVSS 6.5amended

OctoPrint Vulnerable to Denial of Service through malformed HTTP request in OctoPrint

CVE-2025-48879GHSA-9wj4-8h85-pgrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-48879: 0.26% estimated exploitation activity in the next 30 days; percentile 17.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OctoPrint versions up until and including 1.11.1 contain a vulnerability that allows any unauthenticated attacker to send a manipulated broken multipart/form-data request to OctoPrint and through that make the web server component become unresponsive. This could be used to effectively run a denial of service attack on the OctoPrint server. Patches The vulnerability has been patched in version 1.11.2. Workaround OctoPrint administrators are once more reminded to not make OctoPrint available on hostile networks (e.g. the internet), regardless of whether this vulnerability is patched or not. Details The issue can be triggered by a broken multipart/form-data request lacking an end boundary to any of OctoPrint's endpoints implemented through the octoprint.server.util.tornado.UploadStorageFallbackHandler request handler. The request handler will get stuck in an endless busy loop, looking for a part of the request that will never come. As Tornado is single-threaded, that will…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9wj4-8h85-pgrw

  2. Revision 1 · created ·

    Published from osv record GHSA-9wj4-8h85-pgrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48879

Advisory: OctoPrint Vulnerable to Denial of Service through malformed HTTP request in OctoPrint
IDs: CVE-2025-48879, GHSA-9wj4-8h85-pgrw
Record: https://patchnext.com/advisories/cve-2025-48879 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI octoprint: affected < 1.11.2; fixed in 1.11.2

## Suggested inspection (read-only)
- `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octoprint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9wj4-8h85-pgrw (OSV record GHSA-9wj4-8h85-pgrw lists affected ranges: PyPI octoprint >=0 <1.11.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9wj4-8h85-pgrw (GitHub-reviewed advisory GHSA-9wj4-8h85-pgrw lists affected ranges: PyPI octoprint >=0 <1.11.2)

Commands are suggestions: review each one before running it.

Loading voting…