Laravel Rest Api has a Search Validation Bypass
CVE-2025-48490GHSA-69rh-hccr-cxrj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lomkit/laravel-rest-api 2.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist lomkit/laravel-rest-api
- Affected
- < 2.13.0
- Fixed in
- 2.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69rh-hccr-cxrj lists affected ranges: Packagist lomkit/laravel-rest-api >=0 <2.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-48490: 0.64% estimated exploitation activity in the next 30 days; percentile 50.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A validation bypass vulnerability was discovered prior to version 2.13.0, where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. Impact: This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. Patch: The issue was fixed in PR #172 by ensuring that multiple rule definitions are merged correctly rather than overwritten.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69rh-hccr-cxrj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48490 Advisory: Laravel Rest Api has a Search Validation Bypass IDs: CVE-2025-48490, GHSA-69rh-hccr-cxrj Record: https://patchnext.com/advisories/cve-2025-48490 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lomkit/laravel-rest-api 2.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist lomkit/laravel-rest-api: affected < 2.13.0; fixed in 2.13.0 ## Suggested inspection (read-only) - Packagist lomkit/laravel-rest-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lomkit/laravel-rest-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69rh-hccr-cxrj (GitHub-reviewed advisory GHSA-69rh-hccr-cxrj lists affected ranges: Packagist lomkit/laravel-rest-api >=0 <2.13.0) Commands are suggestions: review each one before running it.
Loading voting…