Django Improper Output Neutralization for Logs vulnerability
CVE-2025-48432GHSA-7xr5-9hcq-chf9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django 5.2.2, 5.1.10, 4.2.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django
- Affected
- >= 5.2, < 5.2.2>= 5.0a1, < 5.1.10< 4.2.22
- Fixed in
- 5.1.10, 4.2.22, 5.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7xr5-9hcq-chf9 lists affected ranges: PyPI django >=5.2 =5.0a1 =0 <4.2.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7xr5-9hcq-chf9 lists affected ranges: PyPI django >=5.2 =5.0a1 =0 <4.2.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N
- EPSS
- CVE-2025-48432: 0.81% estimated exploitation activity in the next 30 days; percentile 56.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Django 5.2 before 5.2.2, 5.1 before 5.1.10, and 4.2 before 4.2.22. Internal HTTP response logging does not escape request.path, which allows remote attackers to potentially manipulate log output via crafted URLs. This may lead to log injection or forgery when logs are viewed in terminals or processed by external systems.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7xr5-9hcq-chf9
- Revision 1 · created ·
Published from osv record GHSA-7xr5-9hcq-chf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48432 Advisory: Django Improper Output Neutralization for Logs vulnerability IDs: CVE-2025-48432, GHSA-7xr5-9hcq-chf9 Record: https://patchnext.com/advisories/cve-2025-48432 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django 5.2.2, 5.1.10, 4.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django: affected >= 5.2, < 5.2.2; >= 5.0a1, < 5.1.10; < 4.2.22; fixed in 5.1.10, 4.2.22, 5.2.2 ## Suggested inspection (read-only) - `python -m pip show django`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7xr5-9hcq-chf9 (OSV record GHSA-7xr5-9hcq-chf9 lists affected ranges: PyPI django >=5.2 =5.0a1 =0 <4.2.22 (fixed)) - Verified: https://github.com/advisories/GHSA-7xr5-9hcq-chf9 (GitHub-reviewed advisory GHSA-7xr5-9hcq-chf9 lists affected ranges: PyPI django >=5.2 =5.0a1 =0 <4.2.22) Commands are suggestions: review each one before running it.
Loading voting…