Skip to content

← Actionable
High, CVSS 8.7amended

tar-fs can extract outside the specified dir with a specific tarball

CVE-2025-48387GHSA-8cj5-5rvv-wf4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar-fs 3.0.9, 2.1.3, 1.16.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar-fs

    Affected
    < 1.16.5>= 2.0.0, < 2.1.3>= 3.0.0, < 3.0.9
    Fixed in
    3.0.9, 2.1.3, 1.16.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-48387: 0.58% estimated exploitation activity in the next 30 days; percentile 47.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact v3.0.8, v2.1.2, v1.16.4 and below Patches Has been patched in 3.0.9, 2.1.3, and 1.16.5 Workarounds You can use the ignore option to ignore non files/directories. Credit Thank you Caleb Brown from Google Open Source Security Team for reporting this in detail.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8cj5-5rvv-wf4v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8cj5-5rvv-wf4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48387

Advisory: tar-fs can extract outside the specified dir with a specific tarball
IDs: CVE-2025-48387, GHSA-8cj5-5rvv-wf4v
Record: https://patchnext.com/advisories/cve-2025-48387 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar-fs 3.0.9, 2.1.3, 1.16.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar-fs: affected < 1.16.5; >= 2.0.0, < 2.1.3; >= 3.0.0, < 3.0.9; fixed in 3.0.9, 2.1.3, 1.16.5

## Suggested inspection (read-only)
- `npm ls tar-fs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar-fs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8cj5-5rvv-wf4v (OSV record GHSA-8cj5-5rvv-wf4v lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.9 (fixed))
- Verified: https://github.com/advisories/GHSA-8cj5-5rvv-wf4v (GitHub-reviewed advisory GHSA-8cj5-5rvv-wf4v lists affected ranges: npm tar-fs >=0 =2.0.0 =3.0.0 <3.0.9)

Commands are suggestions: review each one before running it.

Loading voting…