Pillow vulnerability can cause write buffer overflow on BCn encoding
CVE-2025-48379GHSA-xg8h-j46f-w952
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 11.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pillow
- Affected
- >= 11.2.0, < 11.3.0
- Fixed in
- 11.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xg8h-j46f-w952 lists affected ranges: PyPI pillow >=11.2.0 <11.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xg8h-j46f-w952 lists affected ranges: PyPI pillow >=11.2.0 <11.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2025-48379: 0.32% estimated exploitation activity in the next 30 days; percentile 24.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a heap buffer overflow when writing a sufficiently large (64k encoded with default settings) image in the DDS format due to writing into a buffer without checking for available space. This only affects users who save untrusted data as a compressed DDS image. Unclear how large the potential write could be. It is likely limited by process segfault, so it's not necessarily deterministic. It may be practically unbounded. Unclear if there's a restriction on the bytes that could be emitted. It's likely that the only restriction is that the bytes would be emitted in chunks of 8 or 16. This was introduced in Pillow 11.2.0 when the feature was added.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xg8h-j46f-w952
- Revision 1 · created ·
Published from osv record GHSA-xg8h-j46f-w952
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48379 Advisory: Pillow vulnerability can cause write buffer overflow on BCn encoding IDs: CVE-2025-48379, GHSA-xg8h-j46f-w952 Record: https://patchnext.com/advisories/cve-2025-48379 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 11.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pillow: affected >= 11.2.0, < 11.3.0; fixed in 11.3.0 ## Suggested inspection (read-only) - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xg8h-j46f-w952 (OSV record GHSA-xg8h-j46f-w952 lists affected ranges: PyPI pillow >=11.2.0 <11.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xg8h-j46f-w952 (GitHub-reviewed advisory GHSA-xg8h-j46f-w952 lists affected ranges: PyPI pillow >=11.2.0 <11.3.0) Commands are suggestions: review each one before running it.
Loading voting…