OpenFGA Authorization Bypass
CVE-2025-48371GHSA-c72g-53hw-82q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.8.0, < 1.8.13
- Fixed in
- 1.8.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c72g-53hw-82q7 lists affected ranges: Go github.com/openfga/openfga >=1.8.0 <1.8.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-48371: 0.50% estimated exploitation activity in the next 30 days; percentile 43.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Am I Affected? If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability: - Calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset, and - There are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset, and - Those contextual tuples’s user field is an userset, and - Type bound public access tuples are not assigned to the relationship Fix Upgrade to v1.8.13. This upgrade is backwards compatible. Acknowledgments OpenFGA would like to thank @udyvish for discovering this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c72g-53hw-82q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48371 Advisory: OpenFGA Authorization Bypass IDs: CVE-2025-48371, GHSA-c72g-53hw-82q7 Record: https://patchnext.com/advisories/cve-2025-48371 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openfga/openfga: affected >= 1.8.0, < 1.8.13; fixed in 1.8.13 ## Suggested inspection (read-only) - Go github.com/openfga/openfga: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openfga/openfga. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c72g-53hw-82q7 (GitHub-reviewed advisory GHSA-c72g-53hw-82q7 lists affected ranges: Go github.com/openfga/openfga >=1.8.0 <1.8.13) Commands are suggestions: review each one before running it.
Loading voting…