Skip to content

← Actionable
Medium, CVSS 5.1

[clickstorm] SEO (cs_seo) TYPO3 extension Cross-site Scripting (XSS) vulnerability

CVE-2025-48203GHSA-6p8w-pc35-mqv8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (clickstorm/cs-seo 9.3.0, 8.4.0, 7.5.0, 6.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist clickstorm/cs-seo

    Affected
    >= 9.0.0, < 9.3.0>= 8.0.0, < 8.4.0>= 7.0.0, < 7.5.0>= 6.3.0, < 6.8.0
    Fixed in
    8.4.0, 6.8.0, 9.3.0, 7.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L/E:F/RL:O/RC:C
EPSS
  • CVE-2025-48203: 0.25% estimated exploitation activity in the next 30 days; percentile 16.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in the [clickstorm] SEO (csseo) TYPO3 extension allows backend users to execute arbitrary script via the JSON-LD output.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6p8w-pc35-mqv8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48203

Advisory: [clickstorm] SEO (cs_seo) TYPO3 extension Cross-site Scripting (XSS) vulnerability
IDs: CVE-2025-48203, GHSA-6p8w-pc35-mqv8
Record: https://patchnext.com/advisories/cve-2025-48203 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: clickstorm/cs-seo 9.3.0, 8.4.0, 7.5.0, 6.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist clickstorm/cs-seo: affected >= 9.0.0, < 9.3.0; >= 8.0.0, < 8.4.0; >= 7.0.0, < 7.5.0; >= 6.3.0, < 6.8.0; fixed in 8.4.0, 6.8.0, 9.3.0, 7.5.0

## Suggested inspection (read-only)
- Packagist clickstorm/cs-seo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on clickstorm/cs-seo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6p8w-pc35-mqv8 (GitHub-reviewed advisory GHSA-6p8w-pc35-mqv8 lists affected ranges: Packagist clickstorm/cs-seo >=9.0.0 =8.0.0 =7.0.0 =6.3.0 <6.8.0)

Commands are suggestions: review each one before running it.

Loading voting…