Skip to content

← Actionable
Medium, CVSS 6.8amended

OpenEXR Out of Bounds Heap Read due to Bad Pointer Arithmetic in LossyDctDecoder_execute

CVE-2025-48072GHSA-4r7w-q3jg-ff43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openexr

    Affected
    >= 3.3.2, <= 3.3.2
    Fixed in
    3.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-48072: 0.58% estimated exploitation activity in the next 30 days; percentile 47.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenEXRCore code is vulnerable to a heap-based buffer overflow during a read operation due to bad pointer math when decompressing DWAA-packed scan-line EXR files with a maliciously forged chunk. Details In the LossyDctDecoderexecute function (from src/lib/OpenEXRCore/internaldwadecoder.h, when SSE2 is enabled), the following code is used to copy data from the chunks: The issue arises because the src pointer, which is a si128 pointer, is incremented by 88, as if it were a uint16t pointer (64 uint16t == 128 bytes). In non-block aligned chunks (width/height not a multiple of 8), this can cause src to point past the boundaries of the chunk. PoC In order to reproduce the PoC with fidelity and avoid undefined behaviors, it is necessary to enable ASAN (and SSE2). Otherwise the out-of-bound read will not be detected until its side-effect causes a crash. NOTE: please download the dwadecodercrash.exr file from the following link:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4r7w-q3jg-ff43

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4r7w-q3jg-ff43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48072

Advisory: OpenEXR Out of Bounds Heap Read due to Bad Pointer Arithmetic in LossyDctDecoder_execute
IDs: CVE-2025-48072, GHSA-4r7w-q3jg-ff43
Record: https://patchnext.com/advisories/cve-2025-48072 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openexr 3.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openexr: affected >= 3.3.2, <= 3.3.2; fixed in 3.3.3

## Suggested inspection (read-only)
- `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openexr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r7w-q3jg-ff43 (OSV record GHSA-4r7w-q3jg-ff43 lists affected ranges: PyPI openexr >=3.3.2 <3.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-4r7w-q3jg-ff43 (GitHub-reviewed advisory GHSA-4r7w-q3jg-ff43 lists affected ranges: PyPI openexr >=3.3.2 <=3.3.2)

Commands are suggestions: review each one before running it.

Loading voting…