Skip to content

← Actionable
High, CVSS 8.4amended

OpenEXR Heap-Based Buffer Overflow in Deep Scanline Parsing via Forged Unpacked Size

CVE-2025-48071GHSA-h45x-qhg2-q375

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openexr

    Affected
    >= 3.3.0, < 3.3.3
    Fixed in
    3.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-48071: 0.39% estimated exploitation activity in the next 30 days; percentile 33.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenEXRCore code is vulnerable to a heap-based buffer overflow during a write operation when decompressing ZIPS-packed deep scan-line EXR files with a maliciously forged chunk header. Details When parsing STORAGEDEEPSCANLINE chunks from an EXR file, the following code (from src/lib/OpenEXRCore/chunk.c) is used to extract the chunk information: By storing this information, the code that will later decompress and reconstruct the chunk bytes, will know how much space the uncompressed data will occupy. This size is carried along in the chain of decoding/decompression until the undozipimpl function in src/lib/OpenEXRCore/internalzip.c: The uncompressedsize comes from the unpackedsize extracted earlier, and the uncompresseddata is a buffer allocated by making space for the size "advertised" in the chunk information. However, scratchdata and actualoutbytes will contain, after decompression, the uncompressed data and its size, respectively. The vulnerability lies in the fact that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h45x-qhg2-q375

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h45x-qhg2-q375

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48071

Advisory: OpenEXR Heap-Based Buffer Overflow in Deep Scanline Parsing via Forged Unpacked Size
IDs: CVE-2025-48071, GHSA-h45x-qhg2-q375
Record: https://patchnext.com/advisories/cve-2025-48071 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openexr 3.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openexr: affected >= 3.3.0, < 3.3.3; fixed in 3.3.3

## Suggested inspection (read-only)
- `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openexr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h45x-qhg2-q375 (OSV record GHSA-h45x-qhg2-q375 lists affected ranges: PyPI openexr >=3.3.0 <3.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-h45x-qhg2-q375 (GitHub-reviewed advisory GHSA-h45x-qhg2-q375 lists affected ranges: PyPI openexr >=3.3.0 <3.3.3)

Commands are suggestions: review each one before running it.

Loading voting…