OctoPrint vulnerable to possible file extraction via upload endpoints
CVE-2025-48067GHSA-m9jh-jf9h-x3h2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- < 1.11.2
- Fixed in
- 1.11.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m9jh-jf9h-x3h2 lists affected ranges: PyPI octoprint >=0 <1.11.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m9jh-jf9h-x3h2 lists affected ranges: PyPI octoprint >=0 <1.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:L
- EPSS
- CVE-2025-48067: 0.26% estimated exploitation activity in the next 30 days; percentile 18.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up until and including 1.11.1 contain a vulnerability that allows an attacker with the FILEUPLOAD permission to exfiltrate files from the host that OctoPrint has read access to, by moving them into the upload folder where they then can be downloaded from. The primary risk lies in the potential exfiltration of secrets stored inside OctoPrint's config, or further system files. By removing important runtime files, this could also be used to impact the availability of the host. Given that the attacker requires a user account with file upload permissions, the actual impact of this should however hopefully be minimal in most cases. Patches The vulnerability has been patched in version 1.11.2. Details A specially crafted HTTP Request to an affected upload endpoint that contains some form inputs only supposed to be used internally can be used to make OctoPrint move a file that it thinks is a freshly uploaded temporary one into its upload folder. The following…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m9jh-jf9h-x3h2
- Revision 1 · created ·
Published from osv record GHSA-m9jh-jf9h-x3h2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48067 Advisory: OctoPrint vulnerable to possible file extraction via upload endpoints IDs: CVE-2025-48067, GHSA-m9jh-jf9h-x3h2 Record: https://patchnext.com/advisories/cve-2025-48067 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected < 1.11.2; fixed in 1.11.2 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m9jh-jf9h-x3h2 (OSV record GHSA-m9jh-jf9h-x3h2 lists affected ranges: PyPI octoprint >=0 <1.11.2 (fixed)) - Verified: https://github.com/advisories/GHSA-m9jh-jf9h-x3h2 (GitHub-reviewed advisory GHSA-m9jh-jf9h-x3h2 lists affected ranges: PyPI octoprint >=0 <1.11.2) Commands are suggestions: review each one before running it.
Loading voting…